import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http:\\/\\/(?!www\\.)\\w+\\.\\w+(?:\\/.*)?$";
final String string = "http://www.host.com\n"
+ "http://host.com\n"
+ "www.host.com\n"
+ "host.com\n"
+ "http://'anything.'host.com\n"
+ "http://www.host.com\n"
+ "http://sub.host.com\n"
+ "http://host.com/asdsdad";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}