re = /^http:\/\/(?!www\.)\w+\.\w+(?:\/.*)?$/m
str = 'http://www.host.com
http://host.com
www.host.com
host.com
http://\'anything.\'host.com
http://www.host.com
http://sub.host.com
http://host.com/asdsdad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end