const regex = /^http:\/\/(?!www\.)\w+\.\w+(?:\/.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^http:\\\/\\\/(?!www\\.)\\w+\\.\\w+(?:\\\/.*)?$', 'gm')
const str = `http://www.host.com
http://host.com
www.host.com
host.com
http://'anything.'host.com
http://www.host.com
http://sub.host.com
http://host.com/asdsdad`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}