#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?P<question>\w+)\s*(?P<suffix>\(\w+\))?\s*(?::\s*(?P<options>\w+(?:,\s*\w+)*))?\s*\?\s*(?P<type>\w+)"
Local $sString = "Color: Yellow, Green, Red ? ListBox" & @CRLF & _
"Color ? ListBox" & @CRLF & _
"" & @CRLF & _
"Size(mm): Yellow, Green, Red ?ListBox " & @CRLF & _
"Size: Small, Medium, Large ? List" & @CRLF & _
"Age (yrs) ? ListBox"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")