re = /(?P<question>\w+)\s*(?P<suffix>\(\w+\))?\s*(?::\s*(?P<options>\w+(?:,\s*\w+)*))?\s*\?\s*(?P<type>\w+)/
str = 'Color: Yellow, Green, Red ? ListBox
Color ? ListBox
Size(mm): Yellow, Green, Red ?ListBox
Size: Small, Medium, Large ? List
Age (yrs) ? ListBox'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end