// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<question>\w+)\s*(?P<suffix>\(\w+\))?\s*(?::\s*(?P<options>\w+(?:,\s*\w+)*))?\s*\?\s*(?P<type>\w+)").unwrap();
let string = "Color: Yellow, Green, Red ? ListBox
Color ? ListBox
Size(mm): Yellow, Green, Red ?ListBox
Size: Small, Medium, Large ? List
Age (yrs) ? ListBox";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}