using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<question>\w+)\s*(?P<suffix>\(\w+\))?\s*(?::\s*(?P<options>\w+(?:,\s*\w+)*))?\s*\?\s*(?P<type>\w+)";
string input = @"Color: Yellow, Green, Red ? ListBox
Color ? ListBox
Size(mm): Yellow, Green, Red ?ListBox
Size: Small, Medium, Large ? List
Age (yrs) ? ListBox";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}