import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<question>\\w+)\\s*(?P<suffix>\\(\\w+\\))?\\s*(?::\\s*(?P<options>\\w+(?:,\\s*\\w+)*))?\\s*\\?\\s*(?P<type>\\w+)";
final String string = "Color: Yellow, Green, Red ? ListBox\n"
+ "Color ? ListBox\n\n"
+ "Size(mm): Yellow, Green, Red ?ListBox \n"
+ "Size: Small, Medium, Large ? List\n"
+ "Age (yrs) ? ListBox";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}