#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s(?!(?:[^']*'[^']*')*[^']*$)"
Local $sString = "some 'text/abc def ghi dddd dddd '"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)