$re = '/\s(?!(?:[^\']*\'[^\']*\')*[^\']*$)/m';
$str = 'some \'text/abc def ghi dddd dddd \'';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;