import Foundation
let pattern = #"\s(?!(?:[^']*'[^']*')*[^']*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"some 'text/abc def ghi dddd dddd '"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)