using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?!(?:[^']*'[^']*')*[^']*$)";
string substitution = @"-";
string input = @"some 'text/abc def ghi dddd dddd '";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}