const regex = /^(?=\d+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\d+$)', 'gm')
const str = `1111111
1111111
1111111
123something else`;
const subst = `dc.l 0b`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);