re = /^(?=\d+$)/m
str = '1111111
1111111
1111111
123something else'
subst = 'dc.l 0b'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result