use strict;
my $str = '1111111
1111111
1111111
123something else';
my $regex = qr/^(?=\d+$)/mp;
my $subst = 'dc.l 0b';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";