import re
regex = re.compile(r"^(?=\d+$)", flags=re.MULTILINE)
test_str = ("1111111\n"
"1111111\n"
"1111111\n"
"123something else")
subst = "dc.l 0b"
result = regex.sub(subst, test_str)
if result:
print(result)