#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\S+\[v=\"(kennis)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\/data\/(\w+)"
Local $sString = "root/1-825-KennisAPI[v="kennis-adhoc",g="asofdate",p="{"asOfDate":"2017-07-31"}"]/data/as_of_date"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")