package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\S+\[v=\"(kennis)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\/data\/(\w+)`)
var str = `root/1-825-KennisAPI[v="kennis-adhoc",g="asofdate",p="{"asOfDate":"2017-07-31"}"]/data/as_of_date`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}