re = /\S+\[v=\"(kennis)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\/data\/(\w+)/
str = 'root/1-825-KennisAPI[v="kennis-adhoc",g="asofdate",p="{"asOfDate":"2017-07-31"}"]/data/as_of_date'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end