// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\S+\[v=\"(kennis)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\/data\/(\w+)"#).unwrap();
let string = "root/1-825-KennisAPI[v=\"kennis-adhoc\",g=\"asofdate\",p=\"{\"asOfDate\":\"2017-07-31\"}\"]/data/as_of_date";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}