#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(2|t([wo]o?|0))?(b(ee?|3)?)?"
Local $sString = "2" & @CRLF & _
"to" & @CRLF & _
"too" & @CRLF & _
"two" & @CRLF & _
"t0" & @CRLF & _
"b" & @CRLF & _
"be" & @CRLF & _
"bee" & @CRLF & _
"b3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")