import re
regex = re.compile(r"(?i)(2|t([wo]o?|0))?(b(ee?|3)?)?")
test_str = ("2\n"
"to\n"
"too\n"
"two\n"
"t0\n"
"b\n"
"be\n"
"bee\n"
"b3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")