using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(2|t([wo]o?|0))?(b(ee?|3)?)?";
string input = @"2
to
too
two
t0
b
be
bee
b3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}