$re = '/(?i)(2|t([wo]o?|0))?(b(ee?|3)?)?/';
$str = '2
to
too
two
t0
b
be
bee
b3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);