import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(2|t([wo]o?|0))?(b(ee?|3)?)?";
final String string = "2\n"
+ "to\n"
+ "too\n"
+ "two\n"
+ "t0\n"
+ "b\n"
+ "be\n"
+ "bee\n"
+ "b3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}