#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?six)(?<=\n|\A)(?:public\s)?(class|interface|enum)\s([^\n\s]*)"
Local $sString = "/**" & @CRLF & _
" *" & @CRLF & _
" * @author XXXX" & @CRLF & _
" * Introduction: A common interface that judges all kinds of algorithm tags." & @CRLF & _
" * some other comment" & @CRLF & _
" */" & @CRLF & _
"public class TagMatchingInterface " & @CRLF & _
"{" & @CRLF & _
" // content" & @CRLF & _
" public class InnerClazz{" & @CRLF & _
" // content" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")