import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\n|\\A)(?:public\\s)?(class|interface|enum)\\s([^\\n\\s]*)";
final String string = "/**\n"
+ " *\n"
+ " * @author XXXX\n"
+ " * Introduction: A common interface that judges all kinds of algorithm tags.\n"
+ " * some other comment\n"
+ " */\n"
+ "public class TagMatchingInterface \n"
+ "{\n"
+ " // content\n"
+ " public class InnerClazz{\n"
+ " // content\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}