const regex = /(?<=\n|\A)(?:public\s)?(class|interface|enum)\s([^\n\s]*)/gsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\n|\\A)(?:public\\s)?(class|interface|enum)\\s([^\\n\\s]*)', 'gsi')
const str = `/**
*
* @author XXXX
* Introduction: A common interface that judges all kinds of algorithm tags.
* some other comment
*/
public class TagMatchingInterface
{
// content
public class InnerClazz{
// content
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}