import re
regex = re.compile(r"""
(?<=\n|\A)(?:public\s)?(class|interface|enum)\s([^\n\s]*)
""", flags=re.DOTALL | re.IGNORECASE | re.VERBOSE)
test_str = ("/**\n"
" *\n"
" * @author XXXX\n"
" * Introduction: A common interface that judges all kinds of algorithm tags.\n"
" * some other comment\n"
" */\n"
"public class TagMatchingInterface \n"
"{\n"
" // content\n"
" public class InnerClazz{\n"
" // content\n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")