re = /(?<=\n|\A)(?:public\s)?(class|interface|enum)\s([^\n\s]*)/ix
str = '/**
*
* @author XXXX
* Introduction: A common interface that judges all kinds of algorithm tags.
* some other comment
*/
public class TagMatchingInterface
{
// content
public class InnerClazz{
// content
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end