# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"how to"
test_str = ("<li><a href=\"xxx.html\" title=\"xxx\">xxx (22)</a></li>\n"
"<li><a href=\"yyy.html\" title=\"yyy\">yyy (21)</a></li>\n"
"<li><a href=\"zzz.html\" title=\"zzz\">zzz (13)</a></li>\n"
"<li><a href=\"xxx.html\" title=\"xxx\">xxx (23)</a></li>\n"
"<li><a href=\"yyy.html\" title=\"yyy\">yyy (24)</a></li>\n"
"<li><a href=\"zzz.html\" title=\"zzz\">zzz (15)</a></li>\n\n"
"So, this a menu in html. I need to match in order those numbers from the end. Suppose the last line, `<li><a href=\"ccc.html\" title=\"ccc\">ccc (7)</a></li>` instead of (7) I would have (6). The regex formula should match this row.\n\n"
"So, the order of the numbers must be taken into account, and regex formula should match only where the number does not match the default number.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.