import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#\\{[\\w]+\\((\\d+),(\\d+)\\)\\}";
final String string = "#{if(total,0)}#{else}\n"
+ "<div id=\"recommend\">\n"
+ " <div class=\"title\"><p>Title</p></div>\n"
+ " #{item(1,5)}\n"
+ " <div class=\"layout\">\n"
+ " <div class=\"item\">\n"
+ " <a href=\"#{url}\"><img border=\"0\" alt=\"#{name}\" src=\"#{image}\"></a>\n"
+ " </div>\n"
+ " <div class=\"goods\">\n"
+ " <a href=\"#{url}\">#{truncate(name,27)}</a>\n"
+ " </div>\n"
+ " <div class=\"price\">#{comma(price_tax)}</div>\n"
+ " </div>\n"
+ " #{/item}\n"
+ " <br clear=\"all\">\n"
+ "</div>\n"
+ "#{/if}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}