// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"#{[\w]+\((\d+),(\d+)\)}").unwrap();
let string = "#{if(total,0)}#{else}
<div id=\"recommend\">
<div class=\"title\"><p>Title</p></div>
#{item(1,5)}
<div class=\"layout\">
<div class=\"item\">
<a href=\"#{url}\"><img border=\"0\" alt=\"#{name}\" src=\"#{image}\"></a>
</div>
<div class=\"goods\">
<a href=\"#{url}\">#{truncate(name,27)}</a>
</div>
<div class=\"price\">#{comma(price_tax)}</div>
</div>
#{/item}
<br clear=\"all\">
</div>
#{/if}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}