use strict;
my $str = '#{if(total,0)}#{else}
<div id="recommend">
<div class="title"><p>Title</p></div>
#{item(1,5)}
<div class="layout">
<div class="item">
<a href="#{url}"><img border="0" alt="#{name}" src="#{image}"></a>
</div>
<div class="goods">
<a href="#{url}">#{truncate(name,27)}</a>
</div>
<div class="price">#{comma(price_tax)}</div>
</div>
#{/item}
<br clear="all">
</div>
#{/if}';
my $regex = qr/#{[\w]+\((\d+),(\d+)\)}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}