# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"#{[\w]+\((\d+),(\d+)\)}"
test_str = ("#{if(total,0)}#{else}\n"
"<div id=\"recommend\">\n"
" <div class=\"title\"><p>Title</p></div>\n"
" #{item(1,5)}\n"
" <div class=\"layout\">\n"
" <div class=\"item\">\n"
" <a href=\"#{url}\"><img border=\"0\" alt=\"#{name}\" src=\"#{image}\"></a>\n"
" </div>\n"
" <div class=\"goods\">\n"
" <a href=\"#{url}\">#{truncate(name,27)}</a>\n"
" </div>\n"
" <div class=\"price\">#{comma(price_tax)}</div>\n"
" </div>\n"
" #{/item}\n"
" <br clear=\"all\">\n"
"</div>\n"
"#{/if}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.