const regex = /#{[\w]+\((\d+),(\d+)\)}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#{[\\w]+\\((\\d+),(\\d+)\\)}', 'g')
const str = `#{if(total,0)}#{else}
<div id="recommend">
<div class="title"><p>Title</p></div>
#{item(1,5)}
<div class="layout">
<div class="item">
<a href="#{url}"><img border="0" alt="#{name}" src="#{image}"></a>
</div>
<div class="goods">
<a href="#{url}">#{truncate(name,27)}</a>
</div>
<div class="price">#{comma(price_tax)}</div>
</div>
#{/item}
<br clear="all">
</div>
#{/if}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}