using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+|(?=\W)";
string substitution = @"\n";
string input = @"We have not met, have we?";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}