$re = '/\s+|(?=\W)/';
$str = 'We have not met, have we?';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;