use strict;
my $str = 'We have not met, have we?';
my $regex = qr/\s+|(?=\W)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";