const regex = /\s+|(?=\W)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+|(?=\\W)', 'g')
const str = `We have not met, have we?`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);