using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"__t\(\s*[""'](.*)[""']\s*\)";
string input = @"alert(__t('Mingi tekst') );
alert(__t(""Mingi tekst"") );
alert(__t( var_name ) );
__t('Mingi tekst')
function name() {
console.log(__t('sdfsdf'));
}";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}