const regex = /__t\(\s*["'](.*)["']\s*\)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('__t\\(\\s*["\'](.*)["\']\\s*\\)', 'gi')
const str = `alert(__t('Mingi tekst') );
alert(__t("Mingi tekst") );
alert(__t( var_name ) );
__t('Mingi tekst')
function name() {
console.log(__t('sdfsdf'));
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}