import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "__t\\(\\s*[\"'](.*)[\"']\\s*\\)";
final String string = "alert(__t('Mingi tekst') ); \n"
+ "alert(__t(\"Mingi tekst\") );\n"
+ "alert(__t( var_name ) );\n"
+ "__t('Mingi tekst') \n"
+ "function name() {\n"
+ " console.log(__t('sdfsdf'));\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}