re = /__t\(\s*["'](.*)["']\s*\)/i
str = 'alert(__t(\'Mingi tekst\') );
alert(__t("Mingi tekst") );
alert(__t( var_name ) );
__t(\'Mingi tekst\')
function name() {
console.log(__t(\'sdfsdf\'));
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end