package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)__t\(\s*["'](.*)["']\s*\)`)
var str = `alert(__t('Mingi tekst') );
alert(__t("Mingi tekst") );
alert(__t( var_name ) );
__t('Mingi tekst')
function name() {
console.log(__t('sdfsdf'));
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}