use strict;
my $str = 'nfo] Loading project definition from /Users/spandana/projects/gatling-embedded/project
[info] Compiling 1 Scala source to /Users/spandana/projects/gatling-embedded/project/target/scala-2.10/sbt-0.13/classes...
java.lang.[error]: No project \'pbrpclib\' in \'file:/Users/spandana/projects/gatling-embedded/\'.
Valid project IDs: gatling-embedded, root
at scala.sys.package$.error(package.scala:27)
at sbt.Load$';
my $regex = qr/((?i)Exception|(?i)Error)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}