import Foundation
let pattern = #"((?i)Exception|(?i)Error)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
nfo] Loading project definition from /Users/spandana/projects/gatling-embedded/project
[info] Compiling 1 Scala source to /Users/spandana/projects/gatling-embedded/project/target/scala-2.10/sbt-0.13/classes...
java.lang.[error]: No project 'pbrpclib' in 'file:/Users/spandana/projects/gatling-embedded/'.
Valid project IDs: gatling-embedded, root
at scala.sys.package$.error(package.scala:27)
at sbt.Load$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}