// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?i)Exception|(?i)Error)").unwrap();
let string = "nfo] Loading project definition from /Users/spandana/projects/gatling-embedded/project
[info] Compiling 1 Scala source to /Users/spandana/projects/gatling-embedded/project/target/scala-2.10/sbt-0.13/classes...
java.lang.[error]: No project 'pbrpclib' in 'file:/Users/spandana/projects/gatling-embedded/'.
Valid project IDs: gatling-embedded, root
at scala.sys.package$.error(package.scala:27)
at sbt.Load$";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}