#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.+_[0-9]{3}\.wmo$"
Local $sString = "DuskwooAbandoned_Barn.wmo" & @CRLF & _
"DuskwooAbandoned_Barn_000.wmo" & @CRLF & _
"DuskwooAbandoned_Barn_001.wmo" & @CRLF & _
"DuskwooAbandoned_Barn_002.wmo" & @CRLF & _
"" & @CRLF & _
"DuskwooAbandoned_Barn01.wmo" & @CRLF & _
"DuskwooAbandoned_Barn01_000.wmo" & @CRLF & _
"" & @CRLF & _
"DuskwooAbandoned_Barn_01.wmo" & @CRLF & _
"DuskwooAbandoned_Barn_01_000.wmo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")