import re
regex = re.compile(r"^.+_[0-9]{3}\.wmo$", flags=re.MULTILINE)
test_str = ("DuskwooAbandoned_Barn.wmo\n"
"DuskwooAbandoned_Barn_000.wmo\n"
"DuskwooAbandoned_Barn_001.wmo\n"
"DuskwooAbandoned_Barn_002.wmo\n\n"
"DuskwooAbandoned_Barn01.wmo\n"
"DuskwooAbandoned_Barn01_000.wmo\n\n"
"DuskwooAbandoned_Barn_01.wmo\n"
"DuskwooAbandoned_Barn_01_000.wmo")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")